You are here

ELO Browser Information

Latest Licensing News Blog

Important Notice

 

There have been many recent changes to licensure in statute and rule.  Please review the Latest Licensing News blog for updates on current licensing requirements.

 

ELO works best when used with Windows 7 or 8 on a desktop or laptop and one of the following browsers: Internet Explorer 11, Firefox 58, or Chrome 65 (or a higher version of any of these browsers).  

Using ELO on Macintosh OS X or on mobile devices may result in unexpected behavior.

 

Supported Browsers for E-Payment:

  • Microsoft Internet Explorer, versions 11 and above
  • Mozilla Firefox, versions 58 and above
  • Google Chrome, version 65 and above

Also, you must have (1st party) Cookies enabled in your browser.  Error messages that are displayed if Cookies are not enabled:

  • Microsoft Internet Explorer: System Error
  • Mozilla Firefox: Cookies Disabled